LISTSERV at the University of Georgia
Menubar Imagemap
Home Browse Manage Request Manuals Register
Previous messageNext messagePrevious in topicNext in topicPrevious by same authorNext by same authorPrevious page (July 2002, week 3)Back to main SAS-L pageJoin or leave SAS-L (or change settings)ReplyPost a new messageSearchProportional fontNon-proportional font
=========================================================================
Date:         Fri, 19 Jul 2002 13:08:52 +0200
Reply-To:     Ace <b.rogers@VIRGIN.NET>
Sender:       "SAS(r) Discussion" <SAS-L@LISTSERV.UGA.EDU>
From:         Ace <b.rogers@VIRGIN.NET>
Subject:      Re: SUBMIT block problem in v8.2
Content-Type: text/plain; charset=us-ascii

On 19 Jul 2002 01:09:37 -0700, phellema@cc.hut.fi (Pipsa) wrote:

>I am trying to update a SAS/AF v6.09 application to v8.2 but I can't make my >SUBMIT CONTINUE block work the same way it used to work. With the current >option CONTINUE, the SAS statements are not executed before the application >ends. With option IMMEDIATE, the SAS statements are executed immediately, but >the program does not return to the line next to the SUBMIT block. I would like >the application to execute the statements in the block immediately and then >continue with the following statement. How can I make that happen?

I suspect there's some other statements causing your problem. SUBMIT CONTINUE should still work as before, executing the code immediately, then returning control for the SCL to continue processing.

Certainly does for me :-}

Check that you don't have any simple SUBMIT blocks, with no CONTINUE, as the behaviour you're describing would be found.

--


Back to: Top of message | Previous page | Main SAS-L page